Возможно переписать yii2 на php 5.3

Общие вопросы по использованию второй версии фреймворка. Если не знаете как что-то сделать и это про Yii 2, вам сюда.
Жанат
Сообщения: 28
Зарегистрирован: 2013.09.25, 13:57

Возможно переписать yii2 на php 5.3

Сообщение Жанат »

Всем привет!

Возможно переписать yii2 на php 5.3? не возникнут ли проблемы какие-нибудь непреодолимые, типа там каких-то расширений нет или еще что-нибудь просто трейты перепилить или еще какие-нибудь различия в синтаксисе Я смогу, там просто у заказчиков возникло требование о котором не знали и теперь надо быстро перепилить фреймворк на php 5.3.3.

Аватара пользователя
ElisDN
Сообщения: 5606
Зарегистрирован: 2012.10.07, 10:24
Контактная информация:

Re: Возможно переписать yii2 на php 5.3

Сообщение ElisDN »

Жанат писал(а):Не возникнут ли проблемы какие-нибудь непреодолимые?
А что, у заказчиков проблемы какие-нибудь непреодолимые?

Жанат
Сообщения: 28
Зарегистрирован: 2013.09.25, 13:57

Re: Возможно переписать yii2 на php 5.3

Сообщение Жанат »

да, это типа мин обороны и у них лицензия только на php 5.3.3

Жанат
Сообщения: 28
Зарегистрирован: 2013.09.25, 13:57

Re: Возможно переписать yii2 на php 5.3

Сообщение Жанат »

какие могут быть потенциальные проблемы интересно с переписыванием, кроме синтаксиса

Жанат
Сообщения: 28
Зарегистрирован: 2013.09.25, 13:57

Re: Возможно переписать yii2 на php 5.3

Сообщение Жанат »

сейчас смотрю requirements.php, вроде все что там есть по библиотекам есть и в php 5.3.3

Аватара пользователя
ElisDN
Сообщения: 5606
Зарегистрирован: 2012.10.07, 10:24
Контактная информация:

Re: Возможно переписать yii2 на php 5.3

Сообщение ElisDN »

Жанат писал(а):какие могут быть потенциальные проблемы интересно с переписыванием, кроме синтаксиса
Судя по Changelog:

- Added short array syntax support ([1,2,3]).
- Added support for Class::{expr}() syntax.
- Added support for Traits.
- Added closure $this support back.
- Added callable typehint.
- Added indirect method call through array.
- Added class member access on instantiation (e.g. (new foo)->bar()) support.

Жанат
Сообщения: 28
Зарегистрирован: 2013.09.25, 13:57

Re: Возможно переписать yii2 на php 5.3

Сообщение Жанат »

это ясно, чисто синтаксис переписать это возможно, нужно подковырки выяснить необратимые, из-за которых вдруг потом выяснится что это вообще невозможно сделать, прежде чем переписать все на 5.3

Ekstazi
Сообщения: 1428
Зарегистрирован: 2009.08.20, 22:54
Откуда: Молдова, Бельцы
Контактная информация:

Re: Возможно переписать yii2 на php 5.3

Сообщение Ekstazi »

Трейты вроде требуют php 5.4, можно использовать 1-ю версию yii или другой фреймворк. Неймспейсы и там и там можно использовать, как и код писать понятный. Но легче всего php 5.4 поставить на сервер. И от лицензии это не зависит скорее от лени и от фразы: "работает - не трогай" А так - обратная совместимость полная.

Loveorigami
Сообщения: 977
Зарегистрирован: 2014.08.27, 21:54

Re: Возможно переписать yii2 на php 5.3

Сообщение Loveorigami »

Вы фреймворк будете переписывать?
https://github.com/yiisoft/yii2/commit/ ... ce122b8977

Аватара пользователя
girmate
Сообщения: 1533
Зарегистрирован: 2015.10.27, 12:52

Re: Возможно переписать yii2 на php 5.3

Сообщение girmate »

Тогда уж лучше на чистом php.
Осторожно! Вы общаетесь с новичком ;)

Аватара пользователя
samdark
Администратор
Сообщения: 9364
Зарегистрирован: 2009.04.02, 13:46
Откуда: Воронеж
Контактная информация:

Re: Возможно переписать yii2 на php 5.3

Сообщение samdark »

- Added short array syntax support ([1,2,3]).
- Added support for Class::{expr}() syntax.
- Added callable typehint.
- Added indirect method call through array.
- Added closure $this support back.
- Added class member access on instantiation (e.g. (new foo)->bar()) support.
Это не проблема.
- Added support for Traits.
С этим придётся помучаться.

Ещё навскидку проблемы будут с i18n, а именно с intl. Если он, конечно, используется.

Жанат
Сообщения: 28
Зарегистрирован: 2013.09.25, 13:57

Re: Возможно переписать yii2 на php 5.3

Сообщение Жанат »

всем спасибо за ответы!

на счет трейтов - это да, это первое что действительно надо перекрутить, intl для 5.3 вроде есть или там используются какие-то чисто новые возможности для 5.4?

Аватара пользователя
samdark
Администратор
Сообщения: 9364
Зарегистрирован: 2009.04.02, 13:46
Откуда: Воронеж
Контактная информация:

Re: Возможно переписать yii2 на php 5.3

Сообщение samdark »

В intl 5.3 туча багов, которые придётся затыкать. В 5.4 их значительно меньше, но тоже не мало.


Аватара пользователя
Йож
Сообщения: 573
Зарегистрирован: 2015.08.26, 03:05

Re: Возможно переписать yii2 на php 5.3

Сообщение Йож »

"лицензия только на php 5.3.3"
разве php платный? Министерство обороны могло бы свои копейки выделить на апгрейд...

Аватара пользователя
SiZE
Сообщения: 2699
Зарегистрирован: 2011.09.21, 12:39
Откуда: Perm
Контактная информация:

Re: Возможно переписать yii2 на php 5.3

Сообщение SiZE »

Йож писал(а):"лицензия только на php 5.3.3"
разве php платный? Министерство обороны могло бы свои копейки выделить на апгрейд...
Компания прошла лицензирование по секьюрности с такими-то версиями ПО и не может их просто взять и заменить.
в поиске работы

Аватара пользователя
Йож
Сообщения: 573
Зарегистрирован: 2015.08.26, 03:05

Re: Возможно переписать yii2 на php 5.3

Сообщение Йож »

Понял.. Похоже уже лет 10 не проходила повторную проверку :)

Аватара пользователя
SiZE
Сообщения: 2699
Зарегистрирован: 2011.09.21, 12:39
Откуда: Perm
Контактная информация:

Re: Возможно переписать yii2 на php 5.3

Сообщение SiZE »

Йож писал(а):Понял.. Похоже уже лет 10 не проходила повторную проверку :)
Зачем тратить деньги на такую ерунду? )
в поиске работы

Аватара пользователя
Йож
Сообщения: 573
Зарегистрирован: 2015.08.26, 03:05

Re: Возможно переписать yii2 на php 5.3

Сообщение Йож »

Угу, правда жизни.. Программисты пусть решают)

Аватара пользователя
Йож
Сообщения: 573
Зарегистрирован: 2015.08.26, 03:05

Re: Возможно переписать yii2 на php 5.3

Сообщение Йож »

SiZE писал(а):лицензирование по секьюрности с такими-то версиями ПО
Если б они знали, что php 5.3 и секьюрность так далеки... :D
взять хотя бы register_globals

Ответить